「K8S 生态周报」内容主要包含我所接触到的 K8S 生态相关的每周值得推荐的一些信息。欢迎订阅知乎专栏「k8s生态」

Rancher v2.3.3 发布

本周 Rancher v2.3.3 发布,正式支持 Kubernetes v1.16,并将 v1.16.3 设置为 Rancher 默认的 Kubernetes 版本。

在此版本中,值得关注的修复如下:

  • 修复了其不支持 kube-proxy 使用 IPVS 模式的问题;

已知问题:

  • Rancher v2.3.3 在开启 SELinux 的 RHEL 7.7 上使用 RHEL Docker 1.13 时,部署集群将导致失败;

更多关于此版本的特性及已知问题,请关注 ReleaseNote

上游进展

  • api-server 的 --runtime-config 可使用 api/beta=false 参数禁用所有内置的符合 v[0-9]+beta[0-9]+ 版本的 REST API;同时 --feature-gates 可使用 AllBeta=false 禁用所有内置的 beta 特性。#84304

  • downward API 为 Dualstack 增加了支持,参数名为 status.podIPs#83123

项目推荐

介绍一个项目 kube-storage-version-migrator 可帮助你将 Kubernetes 存储在 etcd 中数据迁移至最新的存储版本。

相关的 KEP 在:https://github.com/kubernetes/enhancements/blob/master/keps/sig-api-machinery/0030-storage-migration.md

https://github.com/kubernetes/enhancements/blob/master/keps/sig-api-machinery/storage-migration-auto-trigger.md

题外话

本周整体来看,没有特别多的内容,在接下来的两周内,如果进度正常 Kubernetes v1.17 也就会正式发布了。至此,今年 Kubernetes 的最后一个版本也就正式完成。


可以通过下面二维码订阅我的文章公众号【MoeLove】,在公众号后台回复 k8s 可加入技术圈交流。

TheMoeLove